From cf900075a430bb2c61ef2aae164d0477637be018 Mon Sep 17 00:00:00 2001
From: Antonio Ospite <ao2@ao2.it>
Date: Wed, 18 Nov 2015 15:36:22 +0100
Subject: [PATCH] gbp_retag_commit.sh: check that we are in a debian branch

---
 gbp_retag_commit.sh | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gbp_retag_commit.sh b/gbp_retag_commit.sh
index e2a095b..4bffd36 100755
--- a/gbp_retag_commit.sh
+++ b/gbp_retag_commit.sh
@@ -20,6 +20,11 @@ HASH="$1"
 git cat-file -e "${HASH}^{commit}" || { usage 1>&2; exit 1; }
 
 CHANGELOG_HEADER="$(git show $HASH:debian/changelog | head -1)"
+if [ "x$CHANGELOG_HEADER" = "x" ];
+then
+  echo "Check that the active branch is a debian branch" 1>&2
+  exit 1
+fi
 
 # TODO: give a warning or an error if this is is an UNRELEASED version?
 
-- 
2.1.4