X-Git-Url: https://git.ao2.it/kinect-audio-setup.git/blobdiff_plain/d12c99394cb86bbf9c0657a596a4a26fe2b1c16d..refs/heads/debian:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index ae109ce..7aa6d8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,17 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+PACKAGE = $(shell dh_listpackages)
+TMP     = $(CURDIR)/debian/$(PACKAGE)
 
 %:
 	PREFIX=/usr dh $@ 
+
+override_dh_auto_install:
+	dh_auto_install
+	$(MAKE) install_udev_rules \
+	  DESTDIR=$(TMP) \
+	  LOADER_PATH=/usr/sbin/kinect_upload_fw \
+	  FIRMWARE_PATH=/lib/firmware/kinect/UACFirmware
+
+override_dh_installchangelogs:
+	dh_installchangelogs NEWS