debian/{control,rules}: drop the obsolete -dbg package
[libam7xxx.git] / debian / rules
index c5817c9..36b1f4a 100755 (executable)
@@ -1,9 +1,8 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 
-DEB_LDFLAGS_MAINT_APPEND=-Wl,-Bsymbolic-functions -Wl,--as-needed
-include /usr/share/dpkg/buildflags.mk
-export CFLAGS CPPFLAGS LDFLAGS
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions -Wl,--as-needed
 
 %:
        dh $@
@@ -13,4 +12,4 @@ override_dh_installchangelogs:
 
 .PHONY: override_dh_strip
 override_dh_strip:
-       dh_strip --dbg-package=libam7xxx0.1-dbg
+       dh_strip --dbgsym-migration='libam7xxx0.1-dbg (<< 0.1.7-1~)'