debian/rules: remove the -Wl,--as-needed linker flag
[libam7xxx.git] / debian / rules
index 36b1f4a..a48eb45 100755 (executable)
@@ -2,14 +2,10 @@
 # -*- makefile -*-
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions -Wl,--as-needed
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions
 
 %:
        dh $@
 
 override_dh_installchangelogs:
        dh_installchangelogs NEWS
-
-.PHONY: override_dh_strip
-override_dh_strip:
-       dh_strip --dbgsym-migration='libam7xxx0.1-dbg (<< 0.1.7-1~)'