debian/{control,rules}: drop the obsolete -dbg package
[libam7xxx.git] / debian / rules
index 89ba88d..36b1f4a 100755 (executable)
@@ -1,6 +1,7 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions -Wl,--as-needed
 
 %:
@@ -11,4 +12,4 @@ override_dh_installchangelogs:
 
 .PHONY: override_dh_strip
 override_dh_strip:
-       dh_strip --dbg-package=libam7xxx0.1-dbg
+       dh_strip --dbgsym-migration='libam7xxx0.1-dbg (<< 0.1.7-1~)'