debian/changelog: release package version 0.1.7-1.1
[libam7xxx.git] / debian / rules
index 89ba88d..a48eb45 100755 (executable)
@@ -1,14 +1,11 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 
-export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions -Wl,--as-needed
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions
 
 %:
        dh $@
 
 override_dh_installchangelogs:
        dh_installchangelogs NEWS
-
-.PHONY: override_dh_strip
-override_dh_strip:
-       dh_strip --dbg-package=libam7xxx0.1-dbg