debian/{control,rules}: drop the obsolete -dbg package
[libam7xxx.git] / debian / rules
index 5c88420..36b1f4a 100755 (executable)
@@ -1,13 +1,15 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 
-DEB_LDFLAGS_MAINT_APPEND=-Wl,-Bsymbolic-functions -Wl,--as-needed
-include /usr/share/dpkg/buildflags.mk
-export CFLAGS CPPFLAGS LDFLAGS
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic-functions -Wl,--as-needed
 
 %:
        dh $@
 
+override_dh_installchangelogs:
+       dh_installchangelogs NEWS
+
 .PHONY: override_dh_strip
 override_dh_strip:
-       dh_strip --dbg-package=libam7xxx0.1-dbg
+       dh_strip --dbgsym-migration='libam7xxx0.1-dbg (<< 0.1.7-1~)'